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These instructions explain the process of creating right-of-way data and tabulation sheets 
utilizing the DelDOT R/W Data Program, as well as generating metes and bounds data from 
InRoads. 
 
Currently DelDOT utilizes InRoads V8i SS2 (08.11.07.615) and InRoads V8i SS4 (08.11.09.878). 
This program has been tested with these versions of InRoads. The program will be tested and 
updated as newer versions of InRoads are released. The program will accept up to ten different 
report files to accommodate specific Station and Offset requirements.  This process is explained in 
Appendix-A found later in this document. 
 
The process for generating the right-of-way data and tabulation sheets, for use on all DelDOT 
projects, is a two phase process as listed below: 
 
1. Right-of-Way taking creation and reporting in InRoads. 
2. Data entry in the DelDOT R/W Data Program. 
 
Although these phases are independent of each other, Phase 1 must be completed prior to 
performing the operations in Phase 2. 
 
Phase 1  

1. Define all points and figures for R/W acquisitions.  Some (not all) guidelines for 
acquisitions are listed below. 

 
To easily distinguish the difference between COGO point numbers, it is 
recommended that you use the following guidelines when creating COGO points of 
various types: 
 30000 – 39999 = Alignment points* 
 40000 – 59999 = Existing Right-of-Way and property line points** 
 60000 – 79999 = Proposed Right-of-Way and property line points 
 80000 – 89999 = Grades and Geometric points 
 
*Note: Prior to assigning numbers to COGO points, review the field survey geometry 
file (FS.alg) that has been provided by the Survey Section to insure that you are not 
creating duplicate point numbers. This can be done by checking the COGO Buffer in 
InRoads once the fs.alg file has been opened. 
 
**Note: If a project contains numerous parcels, it is recommended that the points be 
broken out by either a north/south or east/west system. An example would be all 
existing right-of-way or property line points west of your alignment be grouped in 
the 40000-49999 range and all existing right-of-way and property line points east 
of your alignment be grouped in the 50000-59999 range. This helps the Real Estate 
Section when reviewing plans as well as when preparing as acquired deeds. 
 
When creating figures for right-of-way acquisition purposes (PE, TCE or FEE), make 
sure they are created in a clockwise direction. This is stated on page 4 of the “Right-
of-Way Plan/Design Checklist for R/W Verification” and again helps the Real Estate 
Section when reviewing plans and preparing as acquired deeds. 
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2. Select InRoads Menu -> Tools -> XML Reports -> Legal Description... 
 

 
 
 

3. In the Legal Description Dialog, there are three sections. Alignments, Primary Reference 
Alignment, and Secondary Reference Alignments.  In the Alignments section, select the list 
of figures used for the property takes (FEE, TCE, etc.).  In the Secondary Alignments 
section, select the list of baseline(s) of the project in which stations and offsets will be 
given for each point.  The Primary Reference Alignment section should not be used. 
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4. Once each section has been completed, select the Apply button.  This will open the Bentley 
InRoads Report Browser window, as shown below. 
 

 
 

5. Select the "raw-xml.xsl" template from the bottom of the left pane. 
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6. Select File -> Save As... and save the XML file to your project folder. 
 

7. For each XML file that is created, you are required to create a Legal Description document 
that will be sent to the DelDOT Real Estate Section.  To accomplish this, Select 
LegalDescription folder from the left pane. 

 

 
 

8. Select the "deldot_propertydescription.xsl" file from the left pane.  If the entry does not 
exist, please refer to Appendix-B. 
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Phase 2 

The R/W Data Program is currently located at: 
 
Internal Users: \\dotfs08\cadd\web\RWData_Local\ 
 
External Users: http://www.seanduphily.com/RWData_Local/publish.htm.  
 
The above listed address is temporary until a permanent location can be found within the DelDOT 
network.  If your computer does not have the required prerequisites to run the program, a 
message will be displayed on the computer to alert the user to install these prerequisites. 
Currently the program is only available online. 
 

1. After navigating to the web page listed above, select the "Run" button (after prerequisites 
have been installed). 
 

2. The installation will begin and display the Application Run - Security Warning.  Select 
"Run" to continue. The rest of the installation will continue as needed. 

 
3. The RW Data Program - Project Info dialog will display.  Select File -> New Project to start 

a new project, File -> Open Project... to open an existing project file, or File -> Exit to 
close the application. 

 
4. Once the project file is opened, you will be able to enter data into the fields. 

a. Project Number - Project number. 
b. Bridge Number - Bridge number for the project. 
c. Project Name - Project name as it appears on the plan sheets. 
d. County - County location for the project. 
e. Total # R/W Sheets - The total number of sheets in the R/W plan set. 
f. Starting R/W Data Sheet # - This is the first sheet that will be generated by the 

program. 
g. R/W Data / Tab Sheet Designed By - Initials of the person designing the sheets. 
h. R/W Data / Tab Sheet Checked By - Initials of the person checking the sheets. 

There are also three buttons: 
1. Apply Changes - Commits changes to the project database file. 
2. Edit Data - Advances you to the RW Data Program - Project Data dialog. 
3. Exit - Closes the application. 

 

  

file://dotfs08/cadd/web/RWData_Local/
http://www.seanduphily.com/RWData_Local/publish.htm
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5. Clicking the Edit Data button will open the RW Data Program - Project Data dialog. There 
are three separate tables for entering data: 

a. Property Owner Information 
i. Parcel ID - Parcel ID indicated on the R/W plan sheets. 

ii. Parcel Owner - Parcel owner name. 
iii. Assessment Number - Assessment number for the property. 
iv. Title Source - Title source for the property. 
v. Area Method - Method in which the property area was derived. 

vi. Property Area (SF)- Existing property area in square feet. 
vii. Property Area (Acre)- Existing property area in acres. 

viii. Plan Sheet - First R/W plan sheet the property is found on. 
b. Construction / R/W Baseline Info 

i. Alignment Figure # - InRoads figure number for the alignment(s) that 
stations and offsets for point info will be derived from. 

ii. Alignment Description - Non-technical description of the alignment. 
c. Parcel Acquisitions 

i. Parcel ID - The parcel from the Property Owner Info table that the 
acquisition exists for. 

ii. Acquisition Code - The type of acquisition. 
1. R/W - Area occupied by existing R/W 
2. P/E - Permanent Easement 
3. TCE - Temporary Construction Easement 
4. FEE - Area of Acquisition 

iii. Acquisition # - Utilized if multiple similar takes occur on the same property 
(see image for example). 

iv. InRoads Figure # - The InRoads figure number corresponding to the area 
taking. 

v. Remarks - Required remarks for tabulation sheet. 
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6. There are two fields with buttons associated to them: 
a. Select DGN Dir - Selects the directory that the RW Data and Tabulation sheets will 

be generated. 
b. Select XML - Selects the XML files that were generated in Step 1.  Up to ten 

different XML files can be selected for processing. 

 
 

7. There are two arrow buttons to the right of the Parcel Acquisitions table.  These are 
provided to help sort the data.  The order of the data in this table determines the order 
that the data shows on the R/W Data and Tabulation sheets. 
 

8. Property areas will auto compute when the Project Data form is opened and when the 
user clicks on the Update Property Area button.  One entry, either SF or Acre needs to be 
entered.  The Property Area (SF) has control of the Property Area (Acre) column. If you 
change the Property Area (Acre) entry, you must also empty/delete the (SF) entry for the 
program to compute properly, otherwise the auto compute will reset the (Acre) entry to 
equal the existing (SF) entry. 

 
9. The final button is the Create DGN Files button.  Clicking on this does a small data 

validation check and then starts the process of the DGN creation.  InRoads figures used in 
the Parcel Acquisitions section are validated against the figures included in the XML data 
files.  If figures are missing from the XML file(s), then an error message will appear listing 
the figures that are missing and the program will stop processing. 

 
If no errors are detected, then MicroStation will open and you should be able to view the 
generation of each sheet as it happens. 
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Appendix-A 

 Version 2.1.04 introduced the ability to use multiple XML report files.  The point of this 
ability is to force the report of an area of taking to the specific alignment of choice when calling out 
Stations and Offsets.  The following problem describes what can happen and how to solve it: 

 

With the given situation, entering all the figures for property takes and alignments into the Legal 
Description Report dialog could give you unexpected results.   

• Alignments: 80000-80004 
• Secondary Alignments: 1000,2000 

With the above report, instead of getting stations and offsets for figure 80000 from alignment 
1000, you may get them from alignment 2000.  To force InRoads to report on 80000 along only 
1000, you may need to create a separate report. 

• Report 1 
o Alignments: 80000 
o Secondary Alignments: 1000 

• Report 2 
o Alignments: 80001-80004 
o Secondary Alignments: 1000,2000 
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Save each report with a different name (Step 1-6) and make sure to select both XML reports from 
the program dialog (Step 2-6b) 

 

Appendix-B 

 The process now requires a slightly modified XSL file to be used.  Its name is called 
deldot_propertydescription.xsl. 

• Internal DelDOT users – This file should already be present on your system and should get 
updated automatically.  If you do not have the file or experience any other problems, then you 
should contact Sean Duphily (Sean.Duphily@state.de.us) to resolve the issue. 

• External users – The deldot_propertydescription.xsl file should be available on the DelDOT 
DRC for download in the InRoads Files section.  If it is not available, you should contact Michael 
Balbierer (Micheal.Balbierer@state.de.us) for assistance. 

 

R/W Data Program Updates 

• 1.x.x.x - Initial release 
• 2.0.0.3 - Changed the installation to providing access when not connected to the internet. 

This also gives access to more browser types (Chrome, Opera, etc.) to do the installation. 
(8/26/09) 

• 2.1.0.1 - Made the following fixes: 
o Added Update Property Area button to the Project Data form. 
o Property areas auto fill/calculate upon opening Project Data form. 
o Property Area column renamed to Property Area (Acre) 
o Property Area (SF) column added. 
o Alphanumeric characters now acceptable in InRoads Figure # column. These 

characters are not case sensitive. 
o Slight code changes to support MS V8i. 
o Tested and supported on Windows 7. 

• 2.1.0.3 - Made following fixes: 
o Changed the code to include fonts in installation package.  This allows running on 

systems that do not use any DelDOT resources from a default startup of 
MicroStation. 

o Centered text for InRoads Figure # column to maximize number of characters 
allowed. 

o Fixed bug not counting number of lines used on tabulation sheets correctly. 
• 2.1.04 - Made following fixes: 

o Added functionality to include multiple XML reports for processing 

mailto:Sean.Duphily@state.de.us
mailto:Micheal.Balbierer@state.de.us
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o Fixed where the last point entry for each taking wasn't centering the InRoads figure 
number and shifting the rest of the line compared to the rest of the data. 

o Fixed issue when creating a new project from scratch, an error would display. 
• 2.1.05 - Minor bug fixes 

o Fixed issue where figures stored with lower case letters were not getting recognized 
to push data to the second column. 

o Fixed crash when Area Method type was not chosen.  Dashes (-) are now displayed 
when not selected. 

• 2.1.08 – Fixed misspelling in Metes and Bounds sheets. 
• 2.1.09 – Made following fixes: 

o Changed seed file to updated units and added shape to level MC_P_Plot Boundaries. 
o Added code to fix issue with interoperability with MicroStation v8i-SS2 

(08.11.07.443) on Windows 7 x64 machines. 
• 2.2.00 – Structure of the data sheets has been changed due to a request from DelDOT R/W 

section.  Bearing data has been moved up in-line with the point that the course is coming 
from. 

• 3.0.0.3 – Confirmed working on MicroStation SS3 (08.11.09.397), InRoads SS2 
(08.11.07.615) and Windows 8 x64.  Program moved to .NET 4.5 framework. 

• 3.0.0.4 – Changed distances to two decimal places on data sheets. 
• 3.0.0.7 – Added code to check if all InRoads figures noted in the Parcel Acquisitions table are 

identified in the XML files. 
• 3.0.0.10 – Added code to make the program work with MicroStation CONNECT Edition 

(currently Update 4).  The RWData_Local application will run on whichever version of 
MicroStation was last installed on the computer. 
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